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If you have forgotten the password for your Hosted Exchange account you will need to contact Barweb 

Forgot my Password - 

Exchange Account

Currently there is no self service option for a forgotten Hosted Exchange password.



Support



Call us - (07) 3292 0219





Email - helpdesk@barweb.com.au

mailto:helpdesk@barweb.com.au


For verification purposes BarWeb staff will call back on a registered number to confirm the request, a 

confirmation will also be sent once the password has been reset.



1. Go to https://hex.barweb.com.au/owa and login with your email address and current password

2.

Click on the Settings cog in the top right hand corner of the page and select 

Change my password

https://hex.barweb.com.au/owa


Options



3.

Click on General in the top left hand corner of the page and click on 



My account



4.

Click on Change your password 



(You may have to scroll down the page

5. Type in your current password, then a new password and confirm your new password, then click 

save



1. Open Windows Mail

Change Sync Settings - 

Windows Mail
Change Sync Speed



2.

Right click on your account on the left side and select Account Settings



3.

Click Change mailbox sync settings

 

4.

To ensure mail mail arrives real time, change Download new content to "



as items arrive"



5.

Click Done

1. Open Windows Mail
2.

Right click on your account on the left side and select Account Settings

3.

Click 

Change amount of email downloaded



Change mailbox sync settings

4.

Change Download email from to "any time



"

5.

Click Done



1. Log into https://hex.barweb.com.au/owa

Maximum allowed mobile 

phone partnerships

"You have 25 phone partnerships out of the maximum allowed 25 partnerships. After you reach the 

maximum, you can't create additional partnerships until you delete existing ones from your account."

https://hex.barweb.com.au/owa


 with your email account details.

2.

Click the gear icon at the top of the right-hand side of the page and select ' Options



'.

3.

Click Mobile Devices in the left sidebar

4.

Underneath Mobile Devices, select any unused devices and click on the remove icon to delete.  You 



should now be able to create new mobile partnerships.



To disable Out of Office replies, follow the steps below until Step 3, select  Don't send automatic replies then 

Out of Office replies - Set via 

Webmail



click Save.



1. Log into https://hex.barweb.com.au/owa with your email account details 

2.

Click the cog icon at the top right-hand side of the window, then click Set automatic replies

https://hex.barweb.com.au/owa


.

3.

Click Send automatic replies to enable automatic replies 

1.

If you wish to specify a time period, click Send replies only during this time period: and specify the 

period below.
2.



Fill the text box below with the automatic reply you wish to be sent to  internal email addresses.

3.

 If you only want senders in your contact list to receive automatic replies, click Send replies only to 

senders in my Contacts list



, otherwise click Send replies to all external senders.

4.

Fill in the text box below with the automatic reply you wish to be sent to external email addresses. If 

you want the reply to be identical for all senders, copy the text in the internal text box and paste it into 

the external text box.Click Send automatic reply messages to senders outside my organization to 



enable automatic replies to mail received from external email addresses.

5. Click Save



1.

Click on File

2.

Click on Account Settings then 

Add additional mailboxes - 

Outlook 2013/2016/2019

You can only add and open an additional mailbox that you have been granted access to.



Account Settings...



3. Click on Change

4. Click on More Settings

5.

Click on the Advanced tab

6.

Click on the Add...



 button

7.

Type in the email address of the other mailbox and click 



OK



Repeat Steps 6 and 7 for each additional mailbox required

8. Once all mailboxes have been added, click OK

9. Click on 



Next

10.

Click 



Finish





Free space in a full mailbox



Ensure that you have adequate backups of your emails, as once they are deleted from Webmail they 

are not recoverable. For any assistance with backing up your email please contact us at 



1. Log into Webmail by entering in your email account details here https://hex.barweb.com.au/owa

Select the check box besides each email you wish to delete.

helpdesk@barweb.com.au

https://hex.barweb.com.au/owa
mailto:helpdesk@barweb.com.au


Click the drop down triangle next to Filter above your emails, then select Sort by, then 

Size to sort your inbox by emails that consume the most space to emails that consume the 

least.

2.

Click the Delete



 button at the top of the page after selecting the emails to be deleted.

3.

Click Deleted Items on the left of the screen.

4.

Click the Empty button at the top of the screen to remove all emails, or select the check boxes and 

click Delete to remove only selected emails, then click Yes 



on the prompt that appears.

Emails emptied from Trash are deleted permanently.



When you accidentally delete an item from your Outlook mailbox, you can often recover it. The first 
place to look is the Deleted Items or Trash folder. Search for the item you want, then right-click it 
and select Move > Other Folder. If you can't find it there, the next steps depend on what type of 
email account you have in Outlook.

If your folder list looks like this, and you see the Deleted Items folder, see the steps below to 
recover deleted email, appointments, events, contacts, and tasks that have been removed from the 
Deleted Items folder.

If you see the Deleted Items folder, you can recover deleted items.

Image not found or type unknown

If your folder list looks like this, and you see the Trash folder, you can move items from the Trash

folder back into your other folders, but you can't recover items that have been deleted from the Trash 
folder.

If you see the Trash folder, you're using an IMAP account.

Image not found or type unknown

Need to recover a deleted folder in Outlook 2013, Outlook 2016, or Outlook for Office 365?

   You can recover a deleted folder (with all of its messages) if it's still in your Deleted Items folder. 
Unfortunately, you can't recover a folder that's been permanently deleted. But you can use the steps 
in this topic to recover messages from the from the folder you deleted.

Outlook (Windows and Mac) - 

Recover Deleted Items



If you can't find an item in the Deleted Items folder, the next place to look is the Recoverable 

Items folder. This is a hidden folder, and it's the place where items are moved when you do one of 
the following things:

Delete an item from the Deleted Items folder.
Empty the Deleted Items folder.
Permanently delete an item from the inbox or from another folder by selecting it and pressing 
Shift+Delete.

Watch the video or follow the steps listed below the video to recover items from the Recoverable 

Items folder.

 

1. In Outlook, go to your email folder list, and then click Deleted Items.
Important: If you don't see the Deleted Items folder, but instead see the Trash folder, 
then your account doesn't support recovering an item that's no longer in your Deleted 

Items folder.
2. On the Home menu, select Recover Deleted Items From Server.

Select the Deleted Items folder and click Recover Items From Server

Image not found or type unknown

Important: If Recover Deleted Items From Server isn't there, your account doesn't 
support recovering an item that's no longer in your Deleted Items folder.

3. Select the item or items you want to recover, click Restore Selected Items, and then click 
OK.

Recover an item that's no longer in 
your Deleted Items folder



Select an item to restore and click OK

Image not found or type unknown

Where do recovered items go?    When you recover items from the Recoverable Items folder, they 
are moved to the Deleted Items folder. So after you recover an item, you can find it in your Deleted 

Items folder and then move it to another folder.



Once your shared mailbox account is ready you can proceed by adding it to your 

Outlook profile.

You should keep in mind, however, that there are different methods to do this. 

Depending on the infrastructure Exchange Servers are relying on, a shared mailbox 

added using a different method than the one shown below might not work as 

expected, or might produce error messages.

Add an Additional Shared 

Mailbox in Outlook



In Outlook, go to File > Account Settings > Account Settings.

                    

Select your profile and click on Change.

https://kb.barweb.net.au/uploads/images/gallery/2020-02/xNajlfh3niXafScK-1.png


          

Click on More Settings.

https://kb.barweb.net.au/uploads/images/gallery/2020-02/WwyNhNqydKRDjpmj-Outlook-Shared-Mailboxes-How-to-Use-and-Configure-Them-click-on-Change.jpg


    

On the Advanced tab, click Add.

https://kb.barweb.net.au/uploads/images/gallery/2020-02/J1ExwavwrixiuXLJ-Outlook-Shared-Mailboxes-How-to-Use-and-Configure-Them-More-Settings.jpg


                             

Type the email address or name of the shared mailbox, then click OK.

                                             

Once configured, the shared mailbox will be automatically available in the left folder 

pane in Outlook.

https://kb.barweb.net.au/uploads/images/gallery/2020-02/787KFOnOvE6JtNJD-Outlook-Shared-Mailboxes-How-to-Use-and-Configure-Them-Advanced-tab.jpg
https://kb.barweb.net.au/uploads/images/gallery/2020-02/4RSvqIUYKP6enuX3-Outlook-Shared-Mailboxes-How-to-Use-and-Configure-Them-name-of-the-shared-mailbox.jpg


         

 

https://kb.barweb.net.au/uploads/images/gallery/2020-02/xn2hPOQ9Nk49pngj-Outlook-Shared-Mailboxes-How-to-Use-and-Configure-Them-Delegate-Access-Data-File-Properties.png


If you start noticing that your Mac’s Mail app always downloading and is 

continuously or frequently showing a message that it’s “Downloading Messages,” 

you are not alone.

Both OSX and macOS users report this problem with their Mail app. Luckily, 

some fixes do the trick and get your Mac’s Mail App up and working normally 

with no more “downloading messages” errors.

Relaunch the Mail app while holding the Shift key on your keyboard
Change your mail account’s setting for storing the Drafts Mailbox Behaviors to On My Mac
Take your Mail Account offline temporarily and then take them back online
Remove the Mail Account and then add it back
Try rebuilding and reindexing your Mailbox

First, if you’re observing this downloading message at the bottom left of your Mail 

app’s sidebar and it’s only there for a relatively short time, this is normal.

Mail App Always 

Downloading on Mac? How-

To Fix



This message means your Mail app is syncing across your various email 

accounts.

Even though it uses the term downloading it’s actually checking for any syncing 

between accounts. So, the words of wisdom here are: IGNORE IT.

Before you troubleshoot, perform these steps. These might fix your issue, and if not, they prepare 
your Mail for fixing.

1. Delete all messages inside your Deleted Items and Junk (Spam) folders

Mail App Always Downloading: 
Housekeeping

Prep Tips

https://kb.barweb.net.au/uploads/images/gallery/2020-02/a6Ic3PP5S3qLm5Co-Erase-Deleted-Items-in-Mac-Mail-540x360.png


2. Delete any messages you no longer need from your Inbox and other 

mailboxes
3. Update to the latest version of Mail, if possible

 

Quite a few of our readers noted that if they changed the location of where email 

accounts store their drafts that the Mail App started working normally.

1. Open Mail
2. Go to Apple Menu > Preferences > Accounts 
3. Select a mail account
4. Choose the tab Mailbox Behaviors

Change Drafts Mailbox to On My Mac and choose Drafts from the drop-down menu options 

1.  

Change Where Email Stores Your Drafts

Change Draft Settings for Apple’s Mac Mail App

Troubleshoot Mail App Always 
Downloading

https://kb.barweb.net.au/uploads/images/gallery/2020-02/cI6I8Ybm3xpaiWYH-Change-Mac-Mail-App-Drafts-Mailbox-Behavior-to-prevent-email-always-downloading.png


2.

Quit the Mail app by select Mail > Quit Mail. Then, relaunch the Mail app 

while holding the Shift key on your keyboard. This action forces Mail to open 

without displaying any problematic messages.

 
Reload Mail App

3.

But if your problem is more than just that message, you need to put your 

investigative skills to test. The first thing to try and rectify this situation is to 

take your Mail Account offline.

With your Mail App open, navigate to the Menu Bar and select Mailbox. 

From that drop-down menu choose to Take All Accounts Offline.

Take Account Offline

https://kb.barweb.net.au/uploads/images/gallery/2020-02/VAA8kVER263y9T7i-Quit-Mail-on-Mac-540x270.png


Once that completes, return to that menu and this time select Take All 

Accounts Online. See if that solves the problem.

If not, check and see if this problem is happening on one particular account 

or all of your mail accounts. If it’s only happening on one of your accounts, 

turn off that account and then add it back in again.

Turn Off and Back On 
Problematic Account

https://kb.barweb.net.au/uploads/images/gallery/2020-02/MQ6Jch5f9GhD0lXs-Mail-take-Accounts-Offline-540x521.png


Do this by going to Mail > Accounts or Apple Menu > System 

Preferences > Internet Accounts.

Then from the left pane, select your problematic account and choose the 

minus sign.

You’ll see a message asking if you want to delete this account from all 

computers using iCloud Keychain (if applicable), select “Turn Off Account.”

Once the account is off, turn it back on by selecting the account, now listed 

as Inactive and tick the box next to Mail (and anything else you want to sync 

such as Contacts, Calendars, etc.)

Look at Activity Monitor

With your Mail app open, start by navigating to the Menu Bar and select Window. 

In the Window drop-down menu, choose Activity (or press Option+Command+0.)

Selecting Activity shows a small activity monitor that lists any messages currently 

downloading.

 

https://kb.barweb.net.au/uploads/images/gallery/2020-02/idNv8R9DZrVIBM7s-Remove-Internet-Account-on-Mac-540x392.png
https://kb.barweb.net.au/uploads/images/gallery/2020-02/gH96DhzvRqFFAxkC-Add-Mail-Account-for-Mac-540x392.png
https://kb.barweb.net.au/uploads/images/gallery/2020-02/AXuVOzP67OSfgvPB-Mail-Activity-Monitor-540x258.png


1.

2.  

Sometimes, your MacBook pauses a large download to save energy when your 

MacBook is using battery power. If that’s the case, click the button in your Activity 

Monitor to resume downloading.

If your problem wasn’t a paused download, try rebuilding and reindexing your 

Mailbox. It’s best first to delete any email that in your Trash and your Junk folders 

BEFORE you rebuild.

1. Select a mailbox in the Mail sidebar
2. Choose Mailbox > Rebuild

Rebuilding Mailboxes takes a lot of time and once you start there is no pause or 

stop button, so proceed with caution.

Rebuild It

Rebuilding a mailbox updates the list of messages it contains. To rebuild:

https://kb.barweb.net.au/uploads/images/gallery/2020-02/nnKdS7snNWfI5cPy-Downloading-Mail-Messages-540x300.png


Additionally, you must repeat these two steps for each one of your Mailboxes.

And when you rebuild mailboxes for IMAP or Exchange accounts, all the 

messages AND attachments stored locally on your computer are first removed 

and then downloaded again from your mail servers back to your Mac.

That means you’ll use a lot of your network’s bandwidth.

ALSO, your mailbox may appear empty until the download is complete–this 

is normal.

https://kb.barweb.net.au/uploads/images/gallery/2020-02/y3SfoCF96mhKl1Mb-Rebuild-Mailbox-540x540.png


 

Once you rebuild, take a look around your Mail app and mailboxes. If you are still 

having issues with downloading messages, Mail fails to launch, or any other 

problems, it’s time to try a manual reindexing.

The biggest difference between Reindexing and Rebuilding is that while 

rebuilding allows users to select individual mailboxes to be rebuilt, reindexing 

affects ALL Mailboxes.

Reindexing is indeed the nuclear option. It’s the last stop when Mail is so 

unresponsive that it barely works, the search function is not correctly working, or 

the Mail app won’t launch at all. So again, tread with care.

1. Quit Mail App
2. On your Desktop create a folder named OLDMailData
3. Go to Finder
4. From Finder Menu Bar

Press and Hold the Shift Key (or Option Key for some Macs)
Select Go > Library
Locate the Mail Folder
Find a folder titled “V” followed by a number (V4 in my example) 
Locate the MailData folder
Find any file beginning with Envelope Index and move these to your Desktop OLDMailData folder

1.5. Open the Mail app

ReIndex Your Mail

To ReIndex Mac Mail

https://kb.barweb.net.au/uploads/images/gallery/2020-02/VUp5qddGkTgc3PFW-Mac-mail-Folder-Location-in-Library-540x631.png
https://kb.barweb.net.au/uploads/images/gallery/2020-02/TYVe0DLhb4XF2ckL-Mail-Evelope-Files-300x267.png


1. It builds new Envelope Index files but takes a lot of time

If you have thousands or more messages, reindexing takes time–potentially 

hours. But this process fixes a lot of Mail App problems, including constant 

downloading, Mail app not working or responsive, and other message and email 

problems.

Once your Mail app works correctly, go ahead and delete the copies of the 

“Envelope Index” files from your Desktop OLDMailData folder by dumping it in 

the trash.

Close Mail and go to User > Library > Mail to trash this file: 
MessageUidsAlreadyDownloaded

Don’t store your email drafts on the server! Changing this to save drafts on your Mac and then 
restarting Mail fixed the problem for me. Go to Mail App > Preferences > Accounts > 

Mailbox Behaviours and change the Drafts Mailbox to On My Mac

Delete all of your email accounts from Apple Mail and then reinstall them manually one-by-one. 
I did this, and it worked. You must delete ALL of your MAIL ACCOUNTS–not just the ones that 
have problems. So yeah, this one takes time
Log into your email account’s web interface (use a browser) and clear all the draft messages 
there. Then relaunch your Mail app. It looks like it’s worked for my MacBook!
Not an ideal solution but deleting my email accounts from my iPhone solved the problem for me

https://kb.barweb.net.au/uploads/images/gallery/2020-02/8b4boFJtQlcQ8JG2-OldMailData-Folder-300x150.png

